CLIPS Programming 1

Introduction to CLIPS

SEEM 5750
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CLIPS is a tool for building expert systems.

CLIPS is a multiparadigm programming language that provides
support for rule-based, object-oriented, and procedural
programming.

You can download it from:
http://www.se.cuhk.edu.hk/~seem5750/clipswin _executable 6241.zip

— Download clipswin_executable_6241.zip

— Extract the zipped file.
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Select File -> Load to load a clips program
Select Execution -> Reset to reset memory

Select Execution -> Run to execute the
program

Select Execution -> Clear CLIPS to clear the
memory

Select Browse -> Deffacts Manager to list the
name of deffacts construct

Select Browse -> Deftemplate Manager to list
the name of Deftempiate construct

Select Window -> Facts to list the facts in
memory

Select Window -> Agenda to list the rule to
be fired at the current step

Select Window -> Globals Window to list the
globals variance
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CLIPS 6.24
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Dialog Window Facts (MAIM)

[wariabhle family feet)
f-165 [(wvariable live.in.water no)
f-168 [wariable genus dry)

£-170 [(wariable front.teeth no)
f-171 [(wariable species noteeth)
£-175 (wvariakhle pouch no)

f-176 (variable type.ahimal leEHshr_i
b

Defining defrule: remove-rule-no-match +3j+7
Defining defrule: modify-rule-match =j+]j
Defining defrule: rule-satisfied =3j+4]
Defining defrule: ask-question-no-legalwvalues +j+j+3+]

Defining defrule: ask-guestion-legalwvalues +j+3+]

Defining deffacts: knowledge-hase

TEUE

CLIP3> (reset)

CLIP3> (run)

Does wour animal have a backbone? [(ves nol ves

I= the animal warm blooded? [(vyes no) ves

MNormally, does the female of your animal nurse its young with milk? [(yes no) ye

>

Instances (MAIN) |._| |E| |§
[initial-okhject] of INITIAL-CEJECT
Does wour animal eat red meat? (yes no)l no
Does wour animal hawve hoowves? (yes no) no
Does wour aniwal live in water? (vyes no)l no
Does wour animal have large front teeth? (yes nao) ho
Does wour animwal hawve a pouch? [(ves no) no
I think your animal iz & mole/shrew/elephant
CLIPS>

(|

_ Agenda (MAIN) - [B[%] .- Focus (MAIN) - [BX] . Globals (MAIN)

[ »
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e Basic elements of an Expert System
— Fact-list : Global memory for data
— Knowledge-base : Contain all the rules
— Inference Engine : Control overall execution

e A program in CLIPS consists of
— Facts
— Rules

cm
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 Tokens represent groups of characters that have special meaning to CLIPS.
 The group of tokens known as fields is of particular importance.

* There are eight types of fields, also called the CLIPS primitive data types:
— float,
— integer,
— symbol,
— string,
— external address,
— fact address,
— instance name, and
— instance address.

e CLIPS is case-sensitive.
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Floats: 1.5 1.0 9e+l 3.5e10
Integers: 1 +3 -1 65
A symbol, E.g.
e Space-Station
* Fire

e activate_sprinkler_system

— is a field that starts with a printable ASCII character and is followed by zero or more
characters.

* The end of a symbol is reached when a delimiter is encountered.

. gellimiter?ssinclude any nonprintable ASCII character. (spaces, tabs, returns, line feeds) and “ ()
<™
* Symbols cannot contain delimiters.

]ésl'ijring must begin and end with double quotation marks, which are part of the
ield.

— E.g. "Active the sprinkler system.”
External addresses represent the address of an external data structure returned by
a user-defined function (not in the scope of introduction to CLIPS).
A fact address is used to refer to a specific fact.

],cAn instance address is like a fact address, but it refers to an instance rather than a
act.

A series of zero or more fields contained together is referred to as a multifield
value. A multifield value is enclosed by left and right parentheses.
— E.g.

* ()
e (this that)
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The CLIPS prompt appear as follows:
CLIPS>

Commands can be entered directly to CLIPS; this mode is called the top
level.

The normal mode of leaving CLIPS is the exit command.

(exit)
Each CLIPS command must have a matching number of left and right
parentheses.

The final step in executing a CLIPS command after it has been entered
with properly balanced parentheses is to press the return key.

CLIPS> (+ 3 4) |
7

CLIPS> (exit) |
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A symbol surrounded by parentheses is considered to be a command or
function call.

The input (+ 3 4) is a call to the + function.
The input (exit) invokes the exit command.
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To solve a problem, a CLIPS program must have data or information with
which it can reason.

A “chunk” of information in CLIPS is called a fact.

Facts consist of a relation name followed by zero or more slots and their
associated values.
The following is an example of a fact:
(person (name '“John Q. Public™™)
(age 23)
(eye-color blue)
(hatr-color black))
The symbol person is the fact’s relation name and the fact contains four
slots: name, age, eye-color, and hair-color.
— The value of the name slot is “John Q. Public”
— The value of the eye-color slot is blue.
— The value of the hair-color slot is black.
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e The order in which slots are specified is irrelevant. The following fact is
treated as identical to the first person fact by CLIPS.

(person (hair-color black)
(name "John Q. Public'™)
(eye-color blue)

(age 23))



The Deftemplate Construct

Before facts can be created, CLIPS must be informed of the list of valid
slots for a given relation name.

Groups of facts that share the same relation name and contain common
information can be described using the deftemplate construct.
The general format of a deftemplate is:
(deftemplate <relation-name> [<optional-comments]
<slot-definition>*)
The syntax description <slot-definition> is defined as:
(slot <slot-name>) | (multislot <slot-name>)
The deftemplate for the person fact:
(deftemplate person "An example deftemplate"
(slot name)
(slot age)
(slot eye-color)
(slot hair-color))



Multifield Slots

* Multislot keyword in their corresponding deftemplates are allowed to
contain zero or more values

(person (name John Q. Public)
(age 23 )
(eye-color blue)
(hair-color brown))

is illegal if name is a single-field slot, but legal if name is a multifield slot.



Ordered Facts

Facts with a relation name that does not have a corresponding
deftemplate are called ordered facts.

]Ic:or example, a list of numbers could be represented with the following
act:

— (number-1list 7 9 3 4 20)

There are two cases in which ordered facts are useful.

— Facts.consistins of just a relation name are useful as flags and look
identical regardless of whether a deftemplate has been defined. For
example,

* (all-orders-processed)
— For facts containing a single slot, the slot name is usually synonymous
with the relation name. For example, the facts:
(time 8:45)
(food-groups meat dairy bread
fruits-and-vegetables)

e are as meaningful as:
(time (value 8:45))
(food-groups (values meat dairy bread
fruits-and-vegetables))



Ordered Facts

A deftemplate fact is a non-ordered fact.
e Ordered versus Non-ordered

— Ordered facts encode information with fixed position which is not
convenient to access

— Clarity and slot order independence are virtues of deftemplate
facts

— Extra command (e.g. modify, duplicate) for non-ordered facts



Deftemplate Overview

Construct
[S-A T
Deftemplate
IS-/ w
Implied Explicit
Deftempiate Deftempiate
Creates Creates
1S-A IS-A (deftemplate person
Itislot
Ordered Deftemplate gll:t asg; name)
Fact Fact (slot eye-color)
(slot hair-color))
IS-A IS-A
(number-list 7 9 3 4 20) (person) (name John Q. Public)  Multifield Slot
S — (age 23)
Fields Slots 4 (eye-color blue) Single-field Slots
(hair-color brown))
Slot Name Slot Value
Relation Name (a field)
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Basic commands to operate on facts:
— assert, retract, modify, duplicate, facts
Adding Facts

D

— New facts can be added to the fact list using the assert command.

(assert <fact>+)

— As an example,
CLIPS>
(deftemplate person
(slot name)
(slot age)
(slot eye-color)
(slot hair-color))
CLIPS>
(assert (person (name "John Q. Public™)
(age 23)
(eye-color blue)
(hair-color black)))
<Fact-0>
CLIPS>

-3

—t
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e More than one fact can be asserted using a single assert command. For
example, the command:

(assert (person (name "John Q. Public")

(age 23)

(eye-color blue)

(hair-color black))

(person (name' Jane Q. Public')

(age 36)

(eye-color green)

(hair-color red)))
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Displaying Facts
— The facts command can be used to display the facts in the fact list.
(facts)
— For example,
CLIPS> (facts)
-0 (person (name "John Q. Public™)
(age 23)
(eye-color blue)
(hair-color black))
For a total of 1 fact.
CLIPS>

— Every fact that is inserted into the fact list is assigned a unique fact
identifier starting with the letter f and followed by an integer called
the fact index.
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e The complete syntax for the facts command is:

(facts [<start> [<end> [<maximum>]]])
where <start>, <end>, and <maximum> are positive integers.

If no arguments are specified, all facts are displayed.

If the <start> argument is specified, all facts with fact indexes greater than or
equal to <start> are displayed.

If <start> and <end> are specified, all facts with fact indexes greater than or
equal to <start> and less than or equal to <end> are displayed.

Finally, if <maximum> is specified along with <start> and <end>. no more than
<maximum> facts will be displayed.
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e Removing facts

— Removing facts from the fact list is called retraction and is done with
the retract command.

— The syntax of the retract command is:
(retract <fact-index>+)

(retract 0)
— Assingle retract command can be used to retract multiple facts at once.

(retract 0 1)
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e Modifying facts
— Slot values of deftemplate facts can be modified using the modify command.
(modify <fact-index> <slot-modifier>+)
— where <slot-modifier> is:
(<slot-name> <slot-value>)
— For example,
CLIPS> (modify O (age 24))
<Fact-2>
CLIPS> (facts)
-2 (person (nhame "'John Q. Public'™)
(age 24)
(eye-color blue)
(hair-color black))
For a total of 1 fact.
CLIPS>
— A new fact index is generated for a modified fact.
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* Duplicating facts
e duplicate command
CLIPS> (duplicate 2 (name "Jack S. Public*))
<Fact-3>
CLIPS> (facts)
-2 (person (name "John Q. Public'™)
(age 24 )
(eye-color blue)
(hair- color black))
-3 (person (name "Jack S. Public™)
(age 24)
(eye-color blue)
(hair-color black))
For a total of 2 facts.
CLIPS>
 The modify and duplicate commands cannot be used with ordered facts.

 To enable the duplicate command, the following command may be required:
(set-fact-duplication TRUE)
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The watch command is useful for debugging programs.
(watch <watch-i1tem>)

— where <watch-item> is one of the symbols facts, rules, activations,
statistics, compilations, focus, deffunctions, globals, generic-functions,
methods, instances, slots, messages, message-handlers, or all.

If facts are being watched, CLIPS will automatically print a message
indicating that an update has been made to the fact list whenever facts are
asserted or retracted.

The effects of a watch command may be turned off by using the
corresponding unwatch command.

(unwatch <watch-i1tem>)
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CLIPS> (facts 3 3)
-3 (person (name "Jack S. Public')
(age 24)
(eye-color blue)
(hair-color black))
For a total of 1 fact.
CLIPS> (watch facts)
CLIPS> (modify 3 (age 2))
<== -3 (person (name 'Jack S. Public')

(age 24)
(eye-color blue)
(hair-color black))
==> f-4 (person (name "Jack S. Public™)
(age 25)
(eye-color blue)
(hair-color black) )
<Fact-4>
CLIPS>
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It is often convenient to be able to automatically assert a set of facts
instead of typing in the same assertions from the top level.

This is particularly true for facts that are known to be true before running
a program (i.e., the initial knowledge).
Groups of facts that represent initial knowledge can be defined using the
deffacts construct.
(deffacts people "Some people we know'
(person (name "'John Q. Public"™) (age 24)
(eye-color blue) (hair-color black))
(person (name "Jack S. Public"™) (age 24)
(eye-color blue) (hair-color black))
(person (name "Jane Q. Public"™) (age 36)
(eye-color green) (hair-color red)))
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The general format of a deffacts is:

(deffacts <deffacts name> [<optional comment>]
<facts>* )

The facts in a deffacts statement are asserted using the CLIPS reset command.
The reset command removes all facts from the fact list and then asserts the
facts from existing deffacts statement.

(reset)

Even if you have not defined any deffacts statements, a reset will assert the
fact (initial-fact).

— The fact identifier of the initial-fact is always f-0.



The Components of a Rule

Rules can be typed directly into CLIPS or loaded in from a file of rules.

The pseudocode for one of the possible rules in the industrial plant monitoring
expert system is shown as follows:

TIF the emergency is a fire

THEN the response is to activate

the sprinkler system

Before converting the pseudocode to a rule, the deftemplates for the types of facts
referred to by the rule must be defined.

(deftemplate emergency (slot type))

— ;where the type field of the emergency fact would contain symbols such as fire, flood,
and power outage.

(deftemplate response (slot action))
— where the action field of the response fact indicates the response to be taken.
The rule expressed in CLIPS is:

(defrule fTire-emergency "An example rule”

(emergency (type fTire))
=>
(assert (response (action activate-sprinkler-system))))
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The general format of a rule is:

(defrule <rule name> [<comment>]
<patterns>* ; Left-Hand Side (LHS) of the rule
=>
<actions>* ); Right-Hand Side (RHS) of the rule

The entire rule must be surrounded by parentheses and each of the patterns
and actions of the rule must be surrounded by parentheses.

A rule may have multiple patterns and actions. The parentheses surrounding
patterns and actions must be properly balanced if they are nested.

The header of the rule consists of three parts. The rule must start with the
defrule keyword, followed by the name of the rule.

Next comes an optional comment string.



The Components of a Rule

e Example:
- Rule header

(defrule fire-emergency “An example rule"
;, Patterns

(emergency (type fire))
> THEN arrow
=>
; Actions
(assert (response (action activate-sprinkler-syst
e After the rule header are zero or more conditional elements (CEs). The
simplest type of CE is a pattern CE or simply pattern.
— Each pattern consists of one or more constraints intended to match the

fields of a deftemplate fact.

/STem
~ Y 4
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CLIPS attempts to match the patterns of rules against facts in the fact list.

— If all the patterns of a rule match facts, the rule is activated and put on
the agenda, the collection of activated rules.

The arrow is a symbol representing the beginning of the THEN part of an
IF-THEN rule.

— The part of the rule before the arrow is called the left-hand side (LHS)
and the part after the arrow is called the right-hand side (RHS).

The last part of a rule is the list of actions that will be executed when the
rule fires.

— A program normally ceases execution when there are no rules on the
agenda.

— When there are multiple rules on the agenda, CLIPS automatically
determines which is the appropriate rule to fire.
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Execution -- run
A CLIPS program can be made to run with the run command. The syntax of
the run command is:

(run [<Immit>])

— where the optional argument <limit> >is the maximum number of rules to be

fired.
— If <limit> is not included or <limit> is -1, rules will be fired until none

are left on the agenda.

Reset
— Because rules require facts to execute, the reset command is the key method

for starting or restarting an expert system in CLIPS.
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The list of rules on the agenda can be displayed with the agenda
command.

(agenda)

Example:

CLIPS> (reset)

CLIPS> (assert (emergency (type fire)))
<Fact-1>

CLIPS> (agenda)

O Tfire-emergency: -1
For a total of 1 activation.
CLIPS>

The O indicates the salience of the rule on the agenda.
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* With the fire-emergency rule on the agenda, the run command will now
cause the rule to fire.

 The fact (response (action activate-sprinkler-system» will be added to the
fact list as the action of the rule:

CLIPS> (run)
CLIPS> (facts)

-0 (initial-fact)
-1 (emergency (type fire))
-2 (response (action activate-

sprinkler-system))
For a total of 3 facts.

CLIPS>

e Rules in CLIPS exhibit a property called refraction, which means they won't
fire more than once for a specific set of facts.

* Refresh
— The refresh command can be used to make the rule fire again.
e (refresh <rule-name>)



Watching Activations, Rules, and Statistics

e Examples of watching activations:
CLIPS> (reset)

CLIPS> (watch activations)
CLIPS> (assert (emergency (type fire)))

==> Activation O fire-emergency: -1
<Fact-1>

CLIPS> (agenda)

O fiIre-emergency: -1

For a total of 1 activation.

CLIPS> (retract 1)

<== Activation O fire-emergency: f-1
CLIPS> (agenda)

CLIPS>



Watching Activations, Rules, and Statistics

e Rules being watched:

CLIPS> (reset)
CLIPS> (watch rules)
CLIPS> (assert (emergency (type fTire)))

==> Activation O fire-emergency: -1
<Fact-1>

CLIPS> (run)

FIRE 1 fire-emergency: f-I

CLIPS> (agenda)
CLIPS>



Watching Activations, Rules, and Statistics

e |f statistics are watched, informational messages will be printed at the
completion of a run.

CLIPS> (unwatch all)

CLIPS> (reset)

CLIPS> (watch statistics)

CLIPS> (assert (emergency (type fire)))
<Fact-1>

CLIPS> (run)

1 rules fired

3 mean number of facts (3 maximum)

1 mean number of iInstances (1 maximum)
1 mean number of activations (1 maximum)
CLIPS> (unwatch statistics)

CLIPS>



Watching Activations, Rules, and Statistics

CLIPS keeps statistics on the number of facts, activations, and instances.
— The mean number of facts is the sum of the total number of facts in the fact
list after each rule firing divided by the number of rules fired.

The mean and maximum numbers of activations statistics indicate the
average number of activations per rule firing and the largest number of
activations on the agenda for anyone rule firing.



Commands for Manipulating Constructs

Displaying the List of Members of a Specified Construct
— (list-defrules)
— (list-deftemplates)

— (list-deffacts)

Displaying the Text Representation of a Specified Construct Member
— (ppdefrule <defrule-name>)

— (ppdeftemplate <deftemplate-name>)

— (ppdeffacts <deffacts-name>)

Deleting a Specified Construct Member

— (undefrule <defrule-name>)

— (undeftemplate <deftemplate-name>)

— (undeffacts <derfacts-name>)

Clearing All Constructs from the CLIPS Environment

— (clear)
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Besides asserting facts in the RHS of rules, the RHS can also be used to
print out information using the printout command.
(printout <logical-name> <print-itemss>*)

— where <logical-name> indicates the output destination of the printout
command and <print-items>* are the zero or more items to be printed by this
command.

Example of rule using the printout command:
(defrule fire-emergency
(emergency (type fire))
=>
(printout t "Activate the sprinkler system"
crif) )

The logical name t tells CLIPS to send the output to the standard output
device of the computer, usually the terminal.
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In addition to the fire-emergency rule, the expert system monitoring the
industrial plant might include a rule for emergencies in which nooding has
occurred.

(defrule fire-emergency
(emergency (type fire))
=>
(printout t "Activate the sprinkler system"
crif) )
(defrule flood-emergency
(emergency (type flood))
=>
(printout t "Shut down electrical equipment"”
crif) )
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Rules with more than one pattern could be used to express these conditions.
(deftemplate extinguisher-system
(slot type)
(slot status))
(defrule class-A-fire-emergency
(emergency (type class-A-fire))
(extinguisher-system (type water-sprinkler)
(status of¥f))
=>
(printout t "Activate water sprinkler”™ crif))
(defrule class-B-fire-emergency
(emergency (type class-B-fire))
(extinguisher-system (type carbon-dioxide)
(status off))
=>
(printout t "Use carbon dioxide extinguisher"
crit) )
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e Any number of patterns can be placed in a rule.

— The important point to realize is that the rule is placed on the agenda
only if all the patterns are satisfied by facts.

— This type of restriction is called an and conditional element.
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CLIPS has a debugging command called set-break that allows execution to be
halted before any rule from a specified group of rules is fired.

— Arrule that halts execution before being fired is called a breakpoint.
(set-break <rule-name>)
— Example with the following rules:
(defrule first
=>
(assert (fire second)))

(defrule second
(fire second)
=>
(assert (fire third)))

(defrule third
(fire third)
=> )
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— With set-break
CLIPS> (set-break second)
CLIPS> (reset)
CLIPS> (run)

FILE 1 first: £-0
Breaking on the second
CLIPS>

* The show-breaks command can be used to list all breakpoints. Its syntax is:
(show-breaks)

e The remove-break command can be used to remove breakpoints. Its
syntax

(remove-break [<rule-name>])
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 Loading Constructs from a File
(load <file-name>)

— where <file-name> is a string or symbol containing the name of the file to be
loaded.

— E.g. (load “fire.clp”)
e Saving Constructs to a File

— The save command allows the set of constructs stored in CLIPS to be saved to
a disk file.

(save <file-name>)

— E.g. (save “fire.clp”)



Commenting Constructs

A comment in CILPS is any text that begins with a semicolon and ends with a
carriage return.

It is good to include comments describing the constructs, and giving
information regarding the program.
; R R R R T e S R R e S R e S S S B P e S e e
;* Programmer: G. D. Riley *
;* Title: The Fire Program *
;:* Date: 05/17/04 *
; Deftemplate
(deftemplate emergency “template #1”
(slot type)) ; What type of emergency

(deftemplate response “template #2”
(sloto type)) ; How to respond

; The purpose of this rule is to activate
; the sprinkler if there is a fire
(defiruie Tire-emergency “An exampie ruie” ;iF

(emergency (type fire))
=> ; THEN

;Activate the sprinkler system i
(assert (response (action activate-sprinker-system))))



